<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="google-site-verification" content="P9EYDpZQSpvvrBlydaQJK_OgdYFmGoq0Y-BDWq1gXK0" />
<meta name="msvalidate.01" content="43C334F81BEB9DE14F872D6C91B4FC29" />
<meta name="viewport" content="width=1040">
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link href="https://fonts.googleapis.com/css?family=Lato:400,700" rel="stylesheet">
<link rel="stylesheet" href="https://www.chaffeybreeze.com/wp-content/themes/alambre/style.css?1520957106" type="text/css" media="screen, projection" />
<link href="https://www.chaffeybreeze.com/feed" rel="alternate" title="Chaffey Breeze RSS Feed" type="application/rss+xml" />
<link href="https://www.chaffeybreeze.com/feed/atom" rel="alternate" title="Chaffey Breeze Atom Feed" type="application/atom+xml" />
<link href="https://www.chaffeybreeze.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Chaffey Breeze &raquo; Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock Comments Feed" href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html/feed" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.chaffeybreeze.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.2' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.chaffeybreeze.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.chaffeybreeze.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.chaffeybreeze.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Humana Inc (HUM) Director David A. Jr/Ky Jones Sells 600 Shares' href='https://www.chaffeybreeze.com/2019/01/06/humana-inc-hum-director-david-a-jr-ky-jones-sells-600-shares.html' />
<link rel='next' title='Marathon Petroleum (MPC) Stock Rating Upgraded by ValuEngine' href='https://www.chaffeybreeze.com/2019/01/06/marathon-petroleum-mpc-stock-rating-upgraded-by-valuengine.html' />
<meta name="generator" content="WordPress 5.0.2" />
<link rel="canonical" href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" />
<link rel='shortlink' href='https://www.chaffeybreeze.com/?p=2242847' />
<link rel="alternate" type="application/json+oembed" href="https://www.chaffeybreeze.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chaffeybreeze.com%2F2019%2F01%2F06%2Fjay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.chaffeybreeze.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.chaffeybreeze.com%2F2019%2F01%2F06%2Fjay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html&#038;format=xml" />
<link rel="amphtml" href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html/amp" /><link rel="icon" href="https://www.chaffeybreeze.com/wp-content/uploads/2017/09/favicon-chaffey-breeze.png" sizes="32x32" />
<link rel="icon" href="https://www.chaffeybreeze.com/wp-content/uploads/2017/09/favicon-chaffey-breeze.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.chaffeybreeze.com/wp-content/uploads/2017/09/favicon-chaffey-breeze.png" />
<meta name="msapplication-TileImage" content="https://www.chaffeybreeze.com/wp-content/uploads/2017/09/favicon-chaffey-breeze.png" />
<!-- Start Meta Data -->
<title>Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock - Chaffey Breeze</title>
<meta name="description" content="Thermon Group Holdings Inc (NYSE:THR) CFO Jay Peterson purchased 2,000 shares of the business&#8217;s stock in a transaction dated Saturday, November 30th. The stock was bought at an average cost of $22.57 per share, with a total value of $45,140.00. Following the completion of the acquisition, the chief financial officer now directly owns 34,474 shares [&hellip;]" />
<meta name="author" content="Oliver Carreras">
<meta name="news_keywords" content="Thermon Group,NYSE:THR,THR,Computer and Technology,88362T10,Insider Trading, Insider Trades, Stocks" />
<meta name="keywords" content="Thermon Group,NYSE:THR,THR,Computer and Technology,88362T10,Insider Trading, Insider Trades, Stocks" />
<meta name="ticker" content="NYSE:THR" />
<meta name="contentType" content="article">
<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock"/>
<meta name="twitter:description" content="Thermon Group Holdings Inc (NYSE:THR) CFO Jay Peterson purchased 2,000 shares of the business&#8217;s stock in a transaction dated Saturday, November 30th. The stock was bought at an average cost of $22.57 per share, with a total value of $45,140.00. Following the completion of the acquisition, the chief financial officer now directly owns 34,474 shares [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/thermon-group-logo.gif" />
<!-- Open Graph Data -->
<meta property="og:title" content="Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/thermon-group-logo.gif" />
<meta property="og:description" content="Thermon Group Holdings Inc (NYSE:THR) CFO Jay Peterson purchased 2,000 shares of the business&#8217;s stock in a transaction dated Saturday, November 30th. The stock was bought at an average cost of $22.57 per share, with a total value of $45,140.00. Following the completion of the acquisition, the chief financial officer now directly owns 34,474 shares [&hellip;]" />
<meta property="og:site_name" content="Chaffey Breeze" />
<meta property="og:locale" content="en_US" />
<!-- OG Article Template -->
<meta property="article:published_time" content="2019-01-06T08:28:40+0000" />
<meta property="article:modified_time" content="2019-01-06T08:28:40+0000" />
<meta property="article:tag" content="NYSE:THR" />
<meta property="article:tag" content="Thermon Group,NYSE:THR,THR,Computer and Technology,88362T10,Insider Trading, Insider Trades, Stocks" />
<meta property="article:section" content="Stocks" />
<!-- Google meta is in the body-->
	
<!-- End Meta Data -->
	
<script type='text/javascript'>var PopupAdChannel=''; </script>
  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'chaffeybreeze.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "6faadc47-0c09-43a5-b1cf-eb6768938c5b",
      safari_web_id: 'web.onesignal.auto.170dfd78-50f3-4c48-aaba-810262274b60', 
      autoRegister: true,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	<!-- start IMS header tag -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13208068,
				sizes: [[300,250],[300,600],[300,1050]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'ChaffeyBreeze_ROS_RightRail_1'
			});
				
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
	<!-- end IMS header tag -->
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>
<body>

<!-- Start MarketBeat Modern Popup -->
<script type='text/javascript'> var ShowInsiderTradesPopupFirst = true;</script><link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=37"></script>
<script>
	    if (Notification.permission == "denied") { showsecondarynotifications('Chaffey Breeze', 'https://marketbeat.com/images/webpush/get-notifications_chaffey-breeze.png');}
</script>	
	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Chaffey Breeze', 'chaffeybreeze.com', 'NYSE:THR', 'Thermon Group', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/thermon-group-logo.gif');</script>
<!-- End MarketBeat Modern Popup -->


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-top-menu" class="menu"><li id="menu-item-1009" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1009"><a href="http://www.chaffeybreeze.com">Home</a></li>
<li id="menu-item-1010" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1010"><a href="https://www.chaffeybreeze.com/staff">Staff</a></li>
<li id="menu-item-1011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1011"><a href="https://www.chaffeybreeze.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-1012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1012"><a href="https://www.chaffeybreeze.com/about-contact">About/Contact</a></li>
</ul></nav>				<form id="searchform" action="https://www.chaffeybreeze.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->
	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://www.chaffeybreeze.com"><img id="logo" src="/wp-content/uploads/2017/02/chaffey-breeze-logo-01.png" alt="Chaffey Breeze logo"></a>
<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit">

<script type="text/javascript">
   google_ad_client = AdClientID;
   google_ad_slot = "7950057937";
   google_ad_width = 728;
   google_ad_height = 90;
google_ad_channel="6353741138,8569953935"</script>
<!-- Chaffey Breeze 728x90 -->
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

</div> 
<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://www.chaffeybreeze.com/news">News</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="https://www.chaffeybreeze.com/economy">Economy</a></li>
<li id="menu-item-1019" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1019"><a href="https://www.chaffeybreeze.com/stocks">Stocks</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27"><a href="https://www.chaffeybreeze.com/education">Education</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28"><a href="https://www.chaffeybreeze.com/health">Health</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://www.chaffeybreeze.com/technology">Technology</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
<!-- first square unit -->

<div>
<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3356" style="width: 336px; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
</div>
		
<div class="ad336x280">
<script type="text/javascript">
   google_ad_client = AdClientID;
   google_ad_slot = "6473324730";
   google_ad_width = 336;
   google_ad_height = 280;
 google_ad_channel="6353741138,9582167132"+PopupAdChannel;</script>
<!-- Chaffey Breeze -->
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<script type="text/javascript">
   google_ad_client = AdClientID;
   google_ad_slot = "6473324730";
   google_ad_width = 336;
   google_ad_height = 280;
google_ad_channel="6353741138,2058900337"+PopupAdChannel;</script>
<!-- Chaffey Breeze -->
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>
<!-- end second square unit -->

<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Thermon Group</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Thermon Group with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Chaffey Breeze-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:THR" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->

<div>
<a href="https://twitter.com/chaffeybreeze" class="twitter-follow-button" data-show-count="false">Follow @chaffeybreeze</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>
<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FChaffey-Breeze-205132296627177%2F&tabs=timeline&width=336&height=70&small_header=true&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="336" height="70" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>


<!-- Start IMS -->
<div id="ChaffeyBreeze_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('ChaffeyBreeze_ROS_RightRail_1');
			});
			</script>
		</div>
<!--end --> 


<!-- start sponsored posts 
    <div>
    <iframe width="336" height="450" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2353"></iframe>
    </div>
 end sponsored posts -->


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/marathon-petroleum-mpc-stock-rating-upgraded-by-valuengine.html">Marathon Petroleum (MPC) Stock Rating Upgraded by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html">Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/msg-networks-msgn-raised-to-sell-at-valuengine.html">MSG Networks (MSGN) Raised to Sell at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/mcewen-mining-mux-stock-rating-upgraded-by-valuengine.html">McEwen Mining (MUX) Stock Rating Upgraded by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/humana-inc-hum-director-david-a-jr-ky-jones-sells-600-shares.html">Humana Inc (HUM) Director David A. Jr/Ky Jones Sells 600 Shares</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/neophotonics-nptn-lowered-to-buy-at-valuengine.html">NeoPhotonics (NPTN) Lowered to Buy at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/new-york-times-nyt-upgraded-at-valuengine.html">New York Times (NYT) Upgraded at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/peabody-energy-btu-upgraded-at-zacks-investment-research.html">Peabody Energy (BTU) Upgraded at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/angelos-m-stergiou-sells-23277-shares-of-sls-international-inc-sls-stock.html">Angelos M. Stergiou Sells 23,277 Shares of SLS International Inc (SLS) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/ian-audsley-sells-99863-shares-of-prime-media-group-limited-prt-stock.html">Ian Audsley Sells 99,863 Shares of Prime Media Group Limited (PRT) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/james-m-rallo-sells-4090-shares-of-liquidity-services-inc-lqdt-stock.html">James M. Rallo Sells 4,090 Shares of Liquidity Services, Inc. (LQDT) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/calix-calx-raised-to-buy-at-zacks-investment-research.html">Calix (CALX) Raised to &#8220;Buy&#8221; at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/barclays-lowers-citizens-financial-group-cfg-price-target-to-41-00.html">Barclays Lowers Citizens Financial Group (CFG) Price Target to $41.00</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/cbs-cbs-rating-increased-to-overweight-at-stephens.html">CBS (CBS) Rating Increased to Overweight at Stephens</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/bank-of-america-trims-owens-minor-omi-target-price-to-7-00.html">Bank of America Trims Owens &#038; Minor (OMI) Target Price to $7.00</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/gary-vogel-sells-14273-shares-of-eagle-bulk-shipping-inc-egle-stock.html">Gary Vogel Sells 14,273 Shares of Eagle Bulk Shipping Inc. (EGLE) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/valuengine-upgrades-plains-all-american-pipeline-paa-to-sell.html">ValuEngine Upgrades Plains All American Pipeline (PAA) to Sell</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/bank-of-america-bac-earns-equal-weight-rating-from-barclays.html">Bank of America (BAC) Earns Equal Weight Rating from Barclays</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/thomas-j-herzfeld-purchases-16000-shares-of-herzfeld-caribbean-basin-fund-inc-cuba-stock.html">Thomas J. Herzfeld Purchases 16,000 Shares of Herzfeld Caribbean Basin Fund, Inc. (CUBA) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.chaffeybreeze.com/2019/01/06/invacio-inv-market-capitalization-tops-654702-00.html">Invacio (INV) Market Capitalization Tops $654,702.00</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" />
				<h1 itemprop="headline" class="page-title">Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.chaffeybreeze.com/author/oliver" title="Posts by Oliver Carreras" rel="author">Oliver Carreras</a></span> on <span itemprop="datePublished dateModified" content="2019-01-06T08:28:40+0000">Jan 6th, 2019</span> // <a href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html#respond" class="comments-link" >No Comments</a>				</p><!--end .postmeta-->
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->

			
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/thermon-group-logo.gif" alt="Thermon Group logo" title="Thermon Group logo" class="companylogo" />Thermon Group Holdings Inc (NYSE:THR) CFO Jay Peterson purchased 2,000 shares of the business&#8217;s stock in a transaction dated Saturday, November 30th. The stock was bought at an average cost of $22.57 per share, with a total value of $45,140.00. Following the completion of the acquisition, the chief financial officer now directly owns 34,474 shares of the company&#8217;s stock, valued at $778,078.18. The purchase was disclosed in a legal filing with the Securities &amp; Exchange Commission, which is available at <a href='http://www.sec.gov/Archives/edgar/data/1181536/000148909619000017/xslF345X03/wf-form4_154664645198326.xml' target='_blank'>the SEC website</a>. </p>
<p>Shares of <a href='https://www.marketbeat.com/stocks/NYSE/THR/insider-trades/' target='_blank'>THR stock</a> opened at $21.81 on Friday. The company has a current ratio of 3.62, a quick ratio of 2.40 and a debt-to-equity ratio of 0.63. Thermon Group Holdings Inc has a 52-week low of $18.37 and a 52-week high of $27.95. The firm has a market capitalization of $661.03 million, a P/E ratio of 22.03 and a beta of 1.15. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Chaffey Breeze"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:THR" />    <label for="InPostRegistrationEmail">Get <b>Thermon Group</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Thermon Group (NYSE:THR) last issued its quarterly earnings data on Wednesday, October 31st. The technology company reported $0.22 earnings per share (EPS) for the quarter, missing the Zacks&#8217; consensus estimate of $0.23 by ($0.01). Thermon Group had a return on equity of 10.22% and a net margin of 3.45%. The business had revenue of $90.15 million during the quarter, compared to analysts&#8217; expectations of $87.25 million. During the same quarter last year, the business posted $0.22 EPS. The company&#8217;s quarterly revenue was up 46.3% on a year-over-year basis.  On average, analysts predict that  Thermon Group Holdings Inc will post 1.19 EPS for the current year. </p>
<p>		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;">
<script type="text/javascript">
   google_ad_client = AdClientID;
   google_ad_slot = "6473324730";
   google_ad_width = 336;
   google_ad_height = 280;
google_ad_channel="6353741138,2716359938"+PopupAdChannel;</script>
<!-- Chaffey Breeze -->
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
                 </div>

                 Hedge funds have recently modified their holdings of the stock. Rehmann Capital Advisory Group raised its position in shares of  Thermon Group by 1,662.0% in the third quarter. Rehmann Capital Advisory Group now owns 2,784 shares of the technology company&#8217;s stock worth $108,000 after buying an additional 2,626 shares in the last quarter.  Albert D Mason Inc. purchased a new stake in shares of  Thermon Group in the third quarter worth $216,000.  Campbell &#038; CO Investment Adviser LLC purchased a new stake in shares of  Thermon Group in the third quarter worth $230,000.  Dupont Capital Management Corp purchased a new stake in shares of  Thermon Group in the third quarter worth $371,000.  Finally, MetLife Investment Advisors LLC raised its position in  Thermon Group by 51.5% during the third quarter. MetLife Investment Advisors LLC now owns 24,009 shares of the technology company&#8217;s stock valued at $619,000 after purchasing an additional 8,162 shares in the last quarter. </p>
<p>A number of equities analysts have recently commented on the company. TheStreet lowered Thermon Group from a &#8220;b-&#8221; rating to a &#8220;c+&#8221; rating in a report on Wednesday, December 19th. BMO Capital Markets lowered their price objective on Thermon Group from $31.00 to $29.00 and set an &#8220;outperform&#8221; rating on the stock in a research report on Friday, November 2nd. SunTrust Banks upgraded Thermon Group from a &#8220;hold&#8221; rating to a &#8220;buy&#8221; rating and increased their price objective for the stock from $26.00 to $28.00 in a research report on Thursday, November 1st. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> downgraded Thermon Group from a &#8220;strong-buy&#8221; rating to a &#8220;hold&#8221; rating in a research report on Wednesday, October 10th. Finally, <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=THR'>ValuEngine</a> downgraded Thermon Group from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research report on Thursday, November 1st. One research analyst  has rated the stock with a sell rating, two have assigned  a hold rating and two have issued  a buy rating to the stock. The stock currently has an average rating of &#8220;Hold&#8221; and an average target price of $28.50.</p>
<div id='u1302ijdit'>TRADEMARK VIOLATION WARNING: &#8220;Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock&#8221; was  posted by Chaffey Breeze and is owned by of Chaffey Breeze. If you are viewing this news story on another domain, it was stolen and republished in violation of US and international copyright laws. The correct version of this news story can be accessed at https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html. </div>
<p><strong>About Thermon Group</strong></p>
<p>Thermon Group Holdings, Inc provides thermal engineered industrial process heating solutions for process industries in the United States, Canada, Europe, and Asia. Its products include various electric heat tracing cables, steam tracing components, tubing bundles, and instrument and control products, as well as complementary product lines.</p>
<p>Recommended Story: <a href='https://www.marketbeat.com/financial-terms/how-does-quiet-period-work/'>Quiet Period</a><!--ViewCount:ArticleHistoryID=28953195&PostDate=2019-1-6&type=i&tertiary=1&id=315755--></p>
<p><!--Keyword: Thermon Group,NYSE:THR,THR,Computer and Technology,88362T10,Insider Trading, Insider Trades, Stocks--><!--Ratings:4,3,NYSE:THR--></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Thermon Group Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Thermon Group and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:THR&c=Thermon+Group" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Chaffey Breeze-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:THR" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/thermon-group-logo.gif" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.chaffeybreeze.com/wp-content/uploads/2017/02/chaffey-breeze-logo-01.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Chaffey Breeze"/>
					<meta itemprop="url" content="https://chaffeybreeze.com" />
 				</div>
				<!-- end article metadata -->

			</article>


			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.chaffeybreeze.com/2019/01/06/humana-inc-hum-director-david-a-jr-ky-jones-sells-600-shares.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Humana Inc (HUM) Director David A. Jr/Ky Jones Sells 600 Shares</p></div></a>				<a href="https://www.chaffeybreeze.com/2019/01/06/marathon-petroleum-mpc-stock-rating-upgraded-by-valuengine.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Marathon Petroleum (MPC) Stock Rating Upgraded by ValuEngine</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/marathon-petroleum-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Marathon Petroleum  Stock Rating Upgraded by ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.chaffeybreeze.com/2019/01/06/marathon-petroleum-mpc-stock-rating-upgraded-by-valuengine.html" rel="bookmark">Marathon Petroleum  Stock Rating Upgraded by ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/thermon-group-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc  Stock" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" rel="bookmark">Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc  Stock</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/msg-networks-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="MSG Networks  Raised to Sell at ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.chaffeybreeze.com/2019/01/06/msg-networks-msgn-raised-to-sell-at-valuengine.html" rel="bookmark">MSG Networks  Raised to Sell at ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/mcewen-mining-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="McEwen Mining  Stock Rating Upgraded by ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.chaffeybreeze.com/2019/01/06/mcewen-mining-mux-stock-rating-upgraded-by-valuengine.html" rel="bookmark">McEwen Mining  Stock Rating Upgraded by ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/humana_logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Humana Inc  Director David A. Jr/Ky Jones Sells 600 Shares" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.chaffeybreeze.com/2019/01/06/humana-inc-hum-director-david-a-jr-ky-jones-sells-600-shares.html" rel="bookmark">Humana Inc  Director David A. Jr/Ky Jones Sells 600 Shares</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/neophotonics-corp-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="NeoPhotonics  Lowered to Buy at ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.chaffeybreeze.com/2019/01/06/neophotonics-nptn-lowered-to-buy-at-valuengine.html" rel="bookmark">NeoPhotonics  Lowered to Buy at ValuEngine</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	
<div id="respond">
	<h3>Leave a Reply</h3>
	<div class="cancel-comment-reply"> 
		<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html#respond" style="display:none;">Click here to cancel reply.</a></small>
	</div> 
			<form action="https://www.chaffeybreeze.com/wp-comments-post.php" method="post" id="commentform">
 			
			<p>
				<input type="text" name="author" class="txt" id="author" value="" size="22" tabindex="1" />
				<label for="author">Name  (Required) </label>
			</p>
			<p>
				<input type="text" name="email" class="txt" id="email" value="" size="22" tabindex="2" />
				<label for="email">Mail (will not be published)  (Required) </label>
			</p>
			<p>
				<input type="text" name="url" class="txt" id="url" value="" size="22" tabindex="3" />
				<label for="url">Website</label>
			</p>

						<p><textarea autocomplete="nope"  id="8d263f2f71"  name="8d263f2f71"   rows="10" cols="50" tabindex="4"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "98fc222d4b75441d43fa31e0c18732f4" );document.getElementById("8d263f2f71").setAttribute( "id", "comment" );</script></p>
			<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Submit Comment" />
			<input type="hidden" name="comment_post_ID" value="2242847" />
			<input type='hidden' name='comment_post_ID' value='2242847' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
					</form> 
</div> 
</div> 			<!-- end comments section --> 


<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://www.chaffeybreeze.com/news">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26"><a href="https://www.chaffeybreeze.com/economy">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1019"><a href="https://www.chaffeybreeze.com/stocks">Stocks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27"><a href="https://www.chaffeybreeze.com/education">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28"><a href="https://www.chaffeybreeze.com/health">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://www.chaffeybreeze.com/technology">Technology</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2019 <a href="https://www.chaffeybreeze.com">Chaffey Breeze</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.chaffeybreeze.com/wp-includes/js/wp-embed.min.js?ver=5.0.2'></script>
	
<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc $THR Stock https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc $THR Stock https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.chaffeybreeze.com/2019/01/06/jay-peterson-purchases-2000-shares-of-thermon-group-holdings-inc-thr-stock.html&title=Jay Peterson Purchases 2,000 Shares of Thermon Group Holdings Inc (THR) Stock" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Start of StatCounter Code for Chaffey Breeze -->
<script type="text/javascript">
var sc_project=10818136; 
var sc_invisible=1; 
var sc_security="12675ff1"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10818136/0/12675ff1/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Chaffey Breeze -->

		
	<!-- Start of StatCounter Code for Finance Articles -->
		<script type="text/javascript">
		var sc_project=9021069; 
		var sc_invisible=1; 
		var sc_security="fdde5482"; 
		var sc_https=1; 
		document.write("<sc"+"ript type='text/javascript' src='https://www.statcounter.com/counter/counter.js'></" + "script>");
		</script>
		<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
		<!-- End of StatCounter Code for Finance Articles -->
		
<!-- Start of StatCounter Code for Group 2 News Sites -->
<script type="text/javascript">
var sc_project=10694665; 
var sc_invisible=1; 
var sc_security="475eacb4"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" + scJsHost+ "statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><img class="statcounter" src="https://c.statcounter.com/10694665/0/475eacb4/1/"></noscript>
<!-- End of StatCounter Code for Group 2 News Sites -->



<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=28953195&PostDate=2019-1-6&type=i&tertiary=1&id=315755&domain=www.chaffeybreeze.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- One Signal Registration Code -->
<script type="text/javascript">
if(OneSignal.isPushNotificationsSupported())
{
    OneSignal.registerForPushNotifications();
}
</script>
<!-- End Registration Code -->



	</body>

</html>